Cómo instalar Flash Player plugin en Iceweasel – Firefox (Debian 64 bits)

Añado 17-9-2010; ya hay nueva versión en Sid para sistemas 64 bits.

Bueno amigos, llevo unos días de instalaciones en mi nuevo Asus eeePC 1005PE (ya os postearé algo, con Debian y KDE rulando a tope) y aquí os dejo un pequeño truco para instalar el maldito plugin de Flash en Debian 64 bits sin morir en el intento.

A mi el “non-free” que viene en nuestros sources (eliminadlo porque os darán problemas los dos juntos, con gnash no hay pegas) me daba algún fallo y prefiero no forzar una versión de 32 bits a 64 por lo que aprovecharemos el gran trabajo de la gente de Debian Multimedia para instalarlo de un modo tan sencillo como este;

Lo primero, añadir a vuestros “sources.list” los repositorios de Debian Multimedia;

(En este caso testing pero podéis sustituirlo por stable, sid, experimental o unstable)

deb http://www.debian-multimedia.org testing main non-free
deb ftp://ftp.debian-multimedia.org testing main non-free

Luego, bajáis debian-multimedia-keyring y como root, lo instaláis de este modo;

dpkg -i debian-multimedia-keyring_2008.10.16_all.deb

Después, sólo tenéis hacer un aptitude update y aptitude install flashplayer-mozilla, también podéis abrir Synaptic o similares e instalarlo junto a las dependencias incluidas.

Y listo, así de fácil, eso sí, la primera vez cuando abráis el navegador quizás no funcione, recargad la página y ya veréis el “maldito flash” 64 bits desde Debian Multimedia “experimental” en vuestras pantallas ;).

22 pensamientos en “Cómo instalar Flash Player plugin en Iceweasel – Firefox (Debian 64 bits)

  1. Pingback: Tweets that mention Cómo instalar Flash Player plugin en Iceweasel – Firefox (Debian 64 bits) – debianHackers -- Topsy.com

  2. Pues sí, es bien sencillo, aunque en las ramas testing y Sid de debian-multimedia está la versión de 32 bits, y para hacerlo funcionar en 64 te instala el nspluginwrapper, librerías de 32 bits y esas cosas, y no me acaba de ir muy fino que se diga…

    En cambio en debian-multimeda Experimental está la versión “peligrosa”, la 10.0.45, y en 64 bits… no sé qué riesgo correré con ella, pero ahí voy…

    ; )

  3. Hola Miguel -;), por eso lo publiqué, de este modo entra la experimental y para mi todo va mejor que con la de 32 forzada a 64 bits.

    Por cierto, con eso y con un plugin para Iceweasel que uso para reducir la calidad de los ficheros Flash que va muy bien “Low Quality Flash”, por cierto, en el Asus imprescindible, va todo muy fluido, saludos !

  4. Parece interesante y muy sencillo de instalar, ¿que tal de estable es?
    Yo todas las veces que he probado la versión de 64 bits de debian he terminado cansándome por varios problemas y he terminado volviendo a la de 32.
    Uno de los problemas el flashplayer, que si nspluginwrapper, que si chroot, un toston, y al final nunca me iba bien del todo.

    Por cierto. ¡Maldito flashpalyer! Que ganas tengo que termine triunfando el vídeo sobre html5.

  5. buenas otra vez dabo,

    me puse en contacto con el desarrollador de debian-multimedia para preguntarle por ese paquete de 64 bits “agujereado” de experimental, esto fue lo q me dijo (me respondió al momento):

    >10.0.45 is the real 64 bits. You must use the 10.1.53.64 (32 bits) from
    >stable/testing/unstable.

    >I don’t know if Adobe released a new 64 bits version. If yes I’ll update
    >the experimental package if not I’ll remove this package from experimental.

    por si te interesa

    Saludos, : D

  6. #dabo, ¿cómo instalas el sistema en el eepc? cd-usb-externo, usb, pxe…

    Yo tengo un eeepc 1005HA y solo funciona con testing (por el tema wifi) y he tenido bastantes problemas con la instalación con hd-media, así que he acabado montando un servidor para pxe…y fino, fino, fino…

    Indico el enlace del “manolillo” por si alguna le puede interesar:
    http://www.debian-administration.org/articles/478

    PD: Puede funcionar con stable, pero con el kernel del backport y para eso…testing.

  7. Gracias. Había probado con nspluginwrapper y alguna otra cosa (chroot) sin éxito, el flashplayer-nonfree no funciona.

    Gnash no es útil.

    En Gentoo no he tenido problema, pero parece que puede funcionar, en Sid estoy encontrado este problema:

    dpkg: dependency problems prevent configuration of flashplayer-mozilla:
    flashplayer-mozilla depends on ia32-libs-libcurl3; however:
    Package ia32-libs-libcurl3 is not installed.
    flashplayer-mozilla depends on ia32-libs-libnss3; however:
    Package ia32-libs-libnss3 is not installed.
    dpkg: error processing flashplayer-mozilla (–configure):
    dependency problems – leaving unconfigured
    Errors were encountered while processing:
    flashplayer-mozilla

    Current status: 1 broken [+1].

    Pero bueno, a ver si funciona.

  8. Hola amigo, se me pasó contestarte, lo instalo vía pendrive USB aunque también tengo una grabadora externa de DVDs y me lo pilla sin pegas, saludos, a ver si lo lees -;)

  9. Hola j, es otra opción, con la última versión del flash player he tenido que bajarme de adobe el libflashplayer-10.0.45.2.linux-x86_64.so.tar y hacer un cp libflashplayer.so /usr/lib/mozilla/plugins/ para después realizar los enlaces simbólicos (ln -sf /usr/lib/mozilla/plugins/libflashplayer.so /usr/lib/firefox-addons/plugins/) etc.

    Pero vaya que al final siempre se acaba instalando el jodio -;)

    Saludos !

  10. Pingback: Flash Player actualización de seguridad « Cajón desastres

  11. Excelente, muy facil y funciono a la primera. Apenas estoy empezando a trabajar con debian, asi que la ayuda de este tipo me viene de maravilla. Muchas gracias

  12. Dabo, felicitaciones veo que arriba esta bien explicado, te dejo como lo hice en testing, quiza le venga bien a algun user´s

    Manos a la obra:

    1.- descargamos el archivo desde:

    http://www.megaupload.com/?d=GSVKBWKP

    2.- Para que funcione, debemos pegarlo en /usr/lib/mozilla/plugins/

    Desde la consola podemos hacerlo así

    cp /home/net/Downloads/libflashplayer.so /usr/lib/mozilla/plugins/

    Donde “net” es mi usuario ok? ustedes, deben poner el suyo desde la carpeta Downloads.

    Salud y que les sea de provecho.

    Net ;)

    http://www.debianargentina.blogspot.com/

  13. Miguel Angel y Miguel (ON), no acaban de llegar bien las notificaciones y por lo que veo se me pasó contestaros, al primero decirle que es más estable de lo que pueda parecer sólo que cuando da guerra con algún paquete en concreto te puede sacar un poco de tus casillas.

    A Miguel (ON), gracias, anotado queda, claro que me interesa ;)

    Saludos !

  14. Pingback: Actualización de Flash Player corrige grave vulnerabilidad « Cajón desastres

  15. Pingback: Nueva actualización solventa grave vulnerabilidad en Flash Player « Cajón desastres

  16. Pingback: Actualización de Flash Player soluciona grave vulnerabilidad « Cajón desastres

  17. Excelente aportación… Tambien habia intentado “Forzar” la instalación de 32 bits pero no me había funcionado … Gracias !!!

Los comentarios están cerrados.